<!DOCTYPE html>
<html lang="en-US" class="no-js yes-responsive">
<head>
<meta charset="UTF-8">
<meta name="viewport" content="width=device-width, user-scalable=no, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0">
<link rel="profile" href="https://gmpg.org/xfn/11">
<link rel="pingback" href="https://www.antillean.org/xmlrpc.php">

<script>(function(){document.documentElement.className+=' js'})();</script>

<meta name='robots' content='index, follow, max-image-preview:large, max-snippet:-1, max-video-preview:-1' />

<!-- Open Graph Meta Tags generated by MashShare 3.7.9 - https://mashshare.net -->
<meta property="og:type" content="article" /> 
<meta property="og:title" content="Equitable recovery now a key concern for island nations" />
<meta property="og:description" content="The pandemic has compounded the existing vulnerabilities of island nations, and has limited their fiscal ability to respond to the impacts of climate change, as well as the ongoing public health emergency. The Caribbean needs all the support it can get to ensure a sustainable recovery." />
<meta property="og:image" content="https://www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg" />
<meta property="og:url" content="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" />
<meta property="og:site_name" content="Antillean Media Group" />
<meta property="article:publisher" content="https://www.facebook.com/antilleanmedia" />
<meta property="fb:app_id" content="852066808183763" />
<meta property="article:published_time" content="2021-04-13T12:19:11-04:00" />
<meta property="article:modified_time" content="2021-04-13T12:26:13-04:00" />
<meta property="og:updated_time" content="2021-04-13T12:26:13-04:00" />
<!-- Open Graph Meta Tags generated by MashShare 3.7.9 - https://www.mashshare.net -->
<!-- Twitter Card generated by MashShare 3.7.9 - https://www.mashshare.net -->
<meta property="og:image:width" content="800" />
<meta property="og:image:height" content="600" />
<meta name="twitter:card" content="summary_large_image">
<meta name="twitter:title" content="Equitable recovery now a key concern for island nations">
<meta name="twitter:description" content="The pandemic has compounded the existing vulnerabilities of island nations, and has limited their fiscal ability to respond to the impacts of climate change, as well as the ongoing public health emergency. The Caribbean needs all the support it can get to ensure a sustainable recovery.">
<meta name="twitter:image" content="https://www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg">
<meta name="twitter:site" content="@antilleanmedia">
<!-- Twitter Card generated by MashShare 3.7.9 - https://www.mashshare.net -->

<!-- Jetpack Site Verification Tags -->

	<!-- This site is optimized with the Yoast SEO plugin v16.0.2 - https://yoast.com/wordpress/plugins/seo/ -->
	<title>Equitable recovery now a key concern for island nations | Antillean Media Group</title>
	<meta name="description" content="The pandemic has compounded the existing vulnerabilities of island nations, and has limited their fiscal ability to respond to the impacts of climate change, as well as the ongoing public health emergency. The Caribbean needs all the support it can get to ensure a sustainable recovery." />
	<link rel="canonical" href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Equitable recovery now a key concern for island nations | Antillean Media Group" />
	<meta property="og:description" content="The pandemic has compounded the existing vulnerabilities of island nations, and has limited their fiscal ability to respond to the impacts of climate change, as well as the ongoing public health emergency. The Caribbean needs all the support it can get to ensure a sustainable recovery." />
	<meta property="og:url" content="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" />
	<meta property="og:site_name" content="Antillean Media Group" />
	<meta property="article:publisher" content="https://www.facebook.com/antilleanmedia" />
	<meta property="article:published_time" content="2021-04-13T16:19:11+00:00" />
	<meta property="article:modified_time" content="2021-04-13T16:26:13+00:00" />
	<meta property="og:image" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?fit=800%2C600&#038;ssl=1" />
	<meta property="og:image:width" content="800" />
	<meta property="og:image:height" content="600" />
	<meta name="twitter:card" content="summary" />
	<meta name="twitter:creator" content="@antilleanmedia" />
	<meta name="twitter:site" content="@antilleanmedia" />
	<meta name="twitter:label1" content="Written by">
	<meta name="twitter:data1" content="James Ellsmoor">
	<meta name="twitter:label2" content="Est. reading time">
	<meta name="twitter:data2" content="4 minutes">
	<script type="application/ld+json" class="yoast-schema-graph">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</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//jetpack.wordpress.com' />
<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//s1.wp.com' />
<link rel='dns-prefetch' href='//s2.wp.com' />
<link rel='dns-prefetch' href='//public-api.wordpress.com' />
<link rel='dns-prefetch' href='//0.gravatar.com' />
<link rel='dns-prefetch' href='//1.gravatar.com' />
<link rel='dns-prefetch' href='//2.gravatar.com' />
<link rel='dns-prefetch' href='//i0.wp.com' />
<link rel='dns-prefetch' href='//i1.wp.com' />
<link rel='dns-prefetch' href='//i2.wp.com' />
<link rel='dns-prefetch' href='//c0.wp.com' />
<link rel="alternate" type="application/rss+xml" title="Antillean Media Group &raquo; Feed" href="https://www.antillean.org/feed/" />
<link rel="alternate" type="application/rss+xml" title="Antillean Media Group &raquo; Comments Feed" href="https://www.antillean.org/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Antillean Media Group &raquo; Equitable recovery now a key concern for island nations Comments Feed" href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.antillean.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.7.1"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='wp-block-library-css'  href='https://c0.wp.com/c/5.7.1/wp-includes/css/dist/block-library/style.min.css' type='text/css' media='all' />
<style id='wp-block-library-inline-css' type='text/css'>
.has-text-align-justify{text-align:justify;}
</style>
<link rel='stylesheet' id='mashsb-styles-css'  href='https://www.antillean.org/wp-content/plugins/mashsharer/assets/css/mashsb.min.css?ver=3.7.9' type='text/css' media='all' />
<style id='mashsb-styles-inline-css' type='text/css'>
.mashsb-count {color:#00afc6;}@media only screen and (min-width:568px){.mashsb-buttons a {min-width: 150px;}}
</style>
<link rel='stylesheet' id='canos-style-css'  href='https://www.antillean.org/wp-content/themes/amgos/style.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='canos-fontawesome-css'  href='https://www.antillean.org/wp-content/themes/amgos/fonts/font-awesome.min.css?ver=5.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://c0.wp.com/p/jetpack/9.6.1/css/jetpack.css' type='text/css' media='all' />
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/jquery/jquery.min.js' id='jquery-core-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/jquery/jquery-migrate.min.js' id='jquery-migrate-js'></script>
<script type='text/javascript' id='mashsb-js-extra'>
/* <![CDATA[ */
var mashsb = {"shares":"0","round_shares":"1","animate_shares":"1","dynamic_buttons":"0","share_url":"https:\/\/www.antillean.org\/island-nations-equitable-recovery-covid-climate-change-9134\/","title":"Equitable+recovery+now+a+key+concern+for+island+nations","image":"https:\/\/www.antillean.org\/wp-content\/uploads\/2021\/04\/50682282238_955c27f09e_c.jpg","desc":"The pandemic has compounded the existing vulnerabilities of island nations, and has limited their fiscal ability to respond to the impacts of climate change, as well as the ongoing public health emergency. The Caribbean needs all the support it can get to ensure a sustainable recovery.","hashtag":"antilleanmedia","subscribe":"content","subscribe_url":"","activestatus":"1","singular":"1","twitter_popup":"1","refresh":"0","nonce":"9eaff1d788","postid":"16166","servertime":"1618929810","ajaxurl":"https:\/\/www.antillean.org\/wp-admin\/admin-ajax.php"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.antillean.org/wp-content/plugins/mashsharer/assets/js/mashsb.min.js?ver=3.7.9' id='mashsb-js'></script>
<script type='text/javascript' id='nrci_methods-js-extra'>
/* <![CDATA[ */
var nrci_opts = {"gesture":"Y","drag":"Y","touch":"Y","admin":"Y"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.antillean.org/wp-content/plugins/no-right-click-images-plugin/no-right-click-images.js' id='nrci_methods-js'></script>
<link rel="https://api.w.org/" href="https://www.antillean.org/wp-json/" /><link rel="alternate" type="application/json" href="https://www.antillean.org/wp-json/wp/v2/posts/16166" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.antillean.org/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.antillean.org/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.7.1" />
<link rel='shortlink' href='https://wp.me/psTVf-4cK' />
<link rel="alternate" type="application/json+oembed" href="https://www.antillean.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.antillean.org%2Fisland-nations-equitable-recovery-covid-climate-change-9134%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.antillean.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.antillean.org%2Fisland-nations-equitable-recovery-covid-climate-change-9134%2F&#038;format=xml" />
<link rel="apple-touch-icon" sizes="180x180" href="/apple-touch-icon.png">
<link rel="icon" type="image/png" sizes="32x32" href="/favicon-32x32.png">
<link rel="icon" type="image/png" sizes="16x16" href="/favicon-16x16.png">
<link rel="manifest" href="/site.webmanifest">
<link rel="mask-icon" href="/safari-pinned-tab.svg" color="#5bbad5">
<meta name="msapplication-TileColor" content="#da532c">
<meta name="theme-color" content="#ffffff">
<!-- Facebook Pixel Code -->
<script>
  !function(f,b,e,v,n,t,s)
  {if(f.fbq)return;n=f.fbq=function(){n.callMethod?
  n.callMethod.apply(n,arguments):n.queue.push(arguments)};
  if(!f._fbq)f._fbq=n;n.push=n;n.loaded=!0;n.version='2.0';
  n.queue=[];t=b.createElement(e);t.async=!0;
  t.src=v;s=b.getElementsByTagName(e)[0];
  s.parentNode.insertBefore(t,s)}(window, document,'script',
  'https://connect.facebook.net/en_US/fbevents.js');
  fbq('init', '615303848597998');
  fbq('track', 'PageView');
</script>
<noscript><img height="1" width="1" style="display:none"
  src="https://www.facebook.com/tr?id=615303848597998&ev=PageView&noscript=1"
/></noscript>
<!-- End Facebook Pixel Code -->
<script type='text/javascript'>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'http';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://static1.twitcount.com/js/twitcount.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitcount_plugins');</script>
<style type='text/css'>img#wpstats{display:none}</style>
				<style type="text/css">
			button,
			input[type="button"],
			input[type="reset"],
			input[type="submit"],
			.sticky .sticky-post,
			.post-module .entry-cats a,
			#post-meta .entry-cats a,
			.widget_tag_cloud a,
			.canos_widget_newsletter .canos-newsletter-message,
			.canos_widget_social .site-follow a,
			#site-sidebar .canos_widget_newsletter {
			  background-color: #55cbe3;
			}

			a:hover,
			#site-sidebar a:hover,
			#site-sidebar #site-navigation a:hover,
			#site-sidebar #site-navigation .menu > li.current_page_item > a,
			#site-sidebar #site-navigation .menu > li.current-menu-item > a,
			#site-sidebar #site-navigation .menu > li.current_page_ancestor > a {
			  color: #55cbe3;
			}

			.entry-content a:hover,
			.comment-text a:hover,
			.widget_text a:hover,
			.empty-first-post:hover,
			#site-sidebar .widget_text a:hover {
			  border-color: #55cbe3;
			}

			#comments .bypostauthor .comment-author cite {
			  border-bottom: 2px solid #55cbe3;
			}

			
			body,
			button,
			input,
			select,
			textarea {
				font-family: futura-pt;
			}
		</style>
				<style type="text/css">
				/* If html does not have either class, do not show lazy loaded images. */
				html:not( .jetpack-lazy-images-js-enabled ):not( .js ) .jetpack-lazy-image {
					display: none;
				}
			</style>
			<script>
				document.documentElement.classList.add(
					'jetpack-lazy-images-js-enabled'
				);
			</script>
		<link rel="icon" href="https://i1.wp.com/www.antillean.org/wp-content/uploads/2020/10/cropped-logo-ret-blue-1.png?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i1.wp.com/www.antillean.org/wp-content/uploads/2020/10/cropped-logo-ret-blue-1.png?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon" href="https://i1.wp.com/www.antillean.org/wp-content/uploads/2020/10/cropped-logo-ret-blue-1.png?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i1.wp.com/www.antillean.org/wp-content/uploads/2020/10/cropped-logo-ret-blue-1.png?fit=222%2C222&#038;ssl=1" />

<!-- BEGIN Typekit Fonts for WordPress -->
<script>
  (function(d) {
    var config = {
      kitId: 'qeo3zub',
      scriptTimeout: 3000,
      async: true
    },
    h=d.documentElement,t=setTimeout(function(){h.className=h.className.replace(/\bwf-loading\b/g,"")+" wf-inactive";},config.scriptTimeout),tk=d.createElement("script"),f=false,s=d.getElementsByTagName("script")[0],a;h.className+=" wf-loading";tk.src='https://use.typekit.net/'+config.kitId+'.js';tk.async=true;tk.onload=tk.onreadystatechange=function(){a=this.readyState;if(f||a&&a!="complete"&&a!="loaded")return;f=true;clearTimeout(t);try{Typekit.load(config)}catch(e){}};s.parentNode.insertBefore(tk,s)
  })(document);
</script>
<!-- END Typekit Fonts for WordPress -->

		<style type="text/css" id="wp-custom-css">
			#page .wrap h1{
	text-transform:uppercase;
	/*color:#343e47;*/
	font-weight:700;
	/*font-size:60px;*/
	font-family:'futura-pt'
}


.post-sharer li .canos-facebook-share{
	background-color:#000000;
}

.post-sharer li .canos-twitter-share{
	background-color:#000000;
}

.post-sharer li .canos-google-share{
	background-color:#000000;
}

.post-sharer li .canos-linkedin-share{
	background-color:#000000;
}

.post-sharer li .canos-pinterest-share{
		background-color:#000000;
}


.post-sharer li .canos-vk-share{
	display:none;
}

.post-sharer li .canos-google-share{
	display:none;
}

#post-meta .entry-cats a{
	background-color:#e7e7e7;
	color:#000000;
}


#secondary .widget ul{
	position:relative;
	top:-16px;
	left:46px;
}

#page #content #secondary .widget ul{
	width:76% !important;
}

#content #secondary .widget .site-follow li a{
	background-color:#e7e7e7 !important;
}

#page #content #secondary .widget .site-follow li a{
	color:#7d898b !important;
}

.post-modules .entry-cats a{
	background-color:#ffffff;
	color:#0c0c0c;
}


.canos-item-newsletter .canos-newsletter-form input[type=submit]{
	background-color:#55cbe3;
}


.crumbs a span{
	font-weight:400;
	text-transform:none;
	font-size:16px;
}

#main .hentry .entry-content p{
	font-weight:400;
	font-size:20px;
	line-height:32px;
	color:#343e47;
	font-family:'proxima-nova';
}

#main blockquote p{
	font-family:'futura-pt'!important;
	font-size:28px !important;
	line-height:38px !important;
}



#main .wp-caption .wp-caption-text{
	text-align:right;
	line-height:19.7px;
	font-style:normal;
	font-weight:300;
	font-family:'futura-pt';
}


.slides .entry-title a{
	font-family:'futura-pt';
}

.slides li p{
	font-family:'futura-pt';
}

.post-modules .hentry p{
	font-family:'futura-pt';
}

.post-modules .entry-title a{
	font-family:'futura-pt';
}

#canos_widget_module_recent-2 .entry-title a{
	font-family:'futura-pt';
}

#menu-top li{
	font-family:'futura-pt';
}

#colophon .wrap .site-description{
	font-family:'futura-pt';
}

#author-bio p{
	font-family:'futura-pt';
}

#author-bio .author-name a{
	font-family:'futura-pt';
}

#secondary .canos-item-newsletter h4{
	font-family:'futura-pt';
	text-transform:uppercase;
}

.related-posts article p{
	font-family:'futura-pt';
}

#post-meta .entry-cats span{
	font-family:'futura-pt';
}

#post-meta .entry-cats a{
	font-family:'futura-pt';
}

#post-meta p.byline{
	font-family:'futura-pt';
}

#canos_widget_module_recent-2 .hentry .byline{
	font-family:'futura-pt';
}

#canos_widget_module_recent-2 a .entry-date{
	font-family:'futura-pt';
}

#secondary .widget .widget-title{
	font-family:'futura-pt';
}

.related-posts article .entry-title{
	font-family:'futura-pt';
}

#reply-title{
	font-family:'futura-pt';
}

.nav-previous a span{
	font-family:'futura-pt';
}

.canos-newsletter-form .canos-newsletter-field input[type=email]{
	font-family:'futura-pt';
}

.canos-item-newsletter .canos-newsletter-form input[type=submit]{
	font-family:'futura-pt';
}

.site-follow li a{
	position:relative;
	right:-20px;
}
 

#main .hentry .intro{
	font-weight:500;
	font-family:'futura-pt' !important;
}


#main p cite{
	font-style:normal;
	font-size:12px;
	border-top-style:solid;
	border-color:#55cbe3;
	border-top-width:0px;
	border-bottom-style:solid;
	border-bottom-width:1px;
}
	 
#post-meta .author-bio{
	font-size:15px;
}		</style>
		<!-- Jetpack Google Analytics -->
			<script type='text/javascript'>
				var _gaq = _gaq || [];
				_gaq.push(['_setAccount', 'UA-45443034-1']);
_gaq.push(['_trackPageview']);
				(function() {
					var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
					ga.src = ('https:' === document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
					var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
				})();
			</script>
			<!-- End Jetpack Google Analytics -->
</head>

<body data-rsssl=1 class="post-template-default single single-post postid-16166 single-format-standard non-logged-in  right-sidebar">


<div id="site-sidebar" class="widget-area" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<div class="sidebar-navigation">
		<nav id="site-navigation" class="main-navigation" role="navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement">
			<h3 class="semantic">Site navigation</h3>

						<div class="menu-main-container"><ul id="menu-main" class="menu"><li id="menu-item-549" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-549"><a href="https://www.antillean.org/foreign-policy/">CARICOM &amp; Foreign Policy</a></li>
<li id="menu-item-546" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-546"><a href="https://www.antillean.org/business/">Business</a></li>
<li id="menu-item-9469" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9469"><a href="https://www.antillean.org/travel/">Tourism</a></li>
<li id="menu-item-9063" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9063"><a href="https://www.antillean.org/sustainability/">Environment</a></li>
<li id="menu-item-550" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-550"><a href="https://www.antillean.org/health/">Health</a></li>
<li id="menu-item-551" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-551"><a href="https://www.antillean.org/identities/">Identities</a></li>
<li id="menu-item-15243" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-15243"><a href="#">__________________</a></li>
<li id="menu-item-15244" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15244"><a href="https://www.antillean.org/about-us/">About us</a></li>
<li id="menu-item-15707" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15707"><a href="https://www.antillean.org/caribbean-consultancy-services/">Commercial services</a></li>
<li id="menu-item-15248" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15248"><a href="https://www.antillean.org/jobs/">Work with us</a></li>
<li id="menu-item-15247" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15247"><a href="https://www.antillean.org/reprints/">Reprints</a></li>
<li id="menu-item-15246" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15246"><a href="https://www.antillean.org/privacy/">Privacy policy</a></li>
<li id="menu-item-15245" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15245"><a href="https://www.antillean.org/contact-us/">Contact us</a></li>
</ul></div>					</nav><!-- #site-navigation -->

		<aside id="text-7" class="widget widget_text">			<div class="textwidget"><p>Copyright, Antillean Media Group, 2018.</p>
</div>
		</aside>
	</div><!-- .sidebar-navigation -->
</div><!-- #secondary -->

<div id="page" class="hfeed site">
	<a class="skip-link screen-reader-text" href="#content">Skip to content</a>

	
	<header id="masthead" class="site-header has-social" role="banner" itemscope="itemscope" itemtype="http://schema.org/WPHeader">

		<div class="wrap">
			
			<a href="#" id="site-navigation-toggle"><i class="fa fa-bars"></i>Menu</a>

			
		<a href="#" id="site-follow-toggle"><i class="fa fa-plus"></i>Follow</a>

		<ul id="site-follow">
							<li><a href="http://www.facebook.com/antilleanmedia"  title="Facebook"><i class="fa fa-facebook"></i></a></li>
										<li><a href="http://www.twitter.com/antilleanmedia"  title="Twitter"><i class="fa fa-twitter"></i></a></li>
													<li><a href="https://www.linkedin.com/company/antilleanmedia"  title="Linkedin"><i class="fa fa-linkedin"></i></a></li>
																									<li><a href="https://plus.google.com/+antilleanorg1"  title="Google Plus"><i class="fa fa-google-plus"></i></a></li>
																																																		</ul>

		
			<div class="site-branding">
				
					
										<h3 class="site-title semantic" itemprop="headline">Antillean Media Group</h3>
					
					<a href="https://www.antillean.org/" rel="home" class="site-logo"><img id="desktop-logo" src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png" alt="Antillean Media Group" width="300" height="111">
																				<img id="retina-logo" src="https://www.antillean.org/wp-content/uploads/2019/01/logo-ret-blue-1.png" alt="Antillean Media Group" width="600" height="222">
											</a>
					
							</div><!-- .site-branding -->

		</div><!-- .wrap -->
	
	</header><!-- #masthead -->

<div class="wrap">

	<header class="page-header">
		<h1 class="entry-title">Equitable recovery now a key concern for island nations</h1>	</header><!-- .page-header -->

		<ul class="crumbs"><li itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.antillean.org" itemprop="url"><span itemprop="title">Home</span></a></li><li itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a itemprop="url" href="https://www.antillean.org/op-ed/"><span itemprop="title">Opinions &amp; Editorials</span></a></li><li itemscope="itemscope" itemtype="http://data-vocabulary.org/Breadcrumb"><a href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" itemprop="url"><span itemprop="title">Equitable recovery now a key concern for island nations</span></a></li></ul>
</div><!-- .wrap -->

<div id="content" class="site-content wrap">

	<div id="primary" class="content-area">
		<main id="main" class="site-main single-page" role="main">

		
			

<article id="post-16166" class="single-page-post post-16166 post type-post status-publish format-standard has-post-thumbnail hentry category-op-ed category-sustainability" itemscope="itemscope" itemtype="http://schema.org/Article">

		
			<div class="post-thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="800" height="554" src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=800%2C554&amp;ssl=1" class="attachment-canos_833x554 size-canos_833x554 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=800%2C554&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />				<meta itemprop="url" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=800%2C554&#038;ssl=1">
				<meta itemprop="width" content="800">
				<meta itemprop="height" content="554">
			</div>

		
	<div class="entry-content">
		<p><span class="intro"><ins>The pandemic has compounded the existing vulnerabilities of island nations, and has limited their fiscal ability to respond to the impacts of climate change, as well as the ongoing public health emergency. The Caribbean needs all the support it can get to ensure a sustainable recovery.</ins></span></p>
<hr />
<p><span style="font-weight: 400;">Access to investment and finance has defined how island states are able to progress towards achieving the United Nations Sustainable Development Goals (SDGs) and plan their post-pandemic economic recovery. With the pressure of the last twelve months weighing hard on island economies, all eyes are now on how national governments will respond. </span></p>
<p><span style="font-weight: 400;">Policymakers worldwide are keenly anticipating this year’s </span><a href="https://ukcop26.org/" target="_blank" rel="noopener"><span style="font-weight: 400;">COP26</span></a><span style="font-weight: 400;"> UN climate change conference hosted by the United Kingdom. Recovery is set to be one of the major talking points at the summit and delegates are expected to discuss solutions that can create the changes needed for a transition towards a more sustainable economic model. While there have been stipulations in the Paris Agreement that guarantee that larger economic powers help support smaller and developing nations, equitable access finance remains a critical component.</span></p>
<p><span style="font-weight: 400;">United Nations Secretary-General António Guterres </span><a href="https://news.un.org/en/story/2021/03/1088142" target="_blank" rel="noopener"><span style="font-weight: 400;">described</span></a><span style="font-weight: 400;"> this year as being “make or break” in terms of international policy as he called for more virtual opportunities for collaboration ahead of the COP negotiations. Guterres has set the tone for these talks, which has opened the door for upcoming events like this week’s </span><a href="https://islandinnovation.co/finance-forum-2021/" target="_blank" rel="noopener"><span style="font-weight: 400;">Island Finance Forum</span></a><span style="font-weight: 400;"> (IFF) to have a lasting impact, with headline speakers including the Prime Ministers of Saint Lucia and Antigua &amp; Barbuda, in addition to numerous other Caribbean and island delegates calling for fairer financial terms.</span></p>
<p><b>Global Context: </b><span style="font-weight: 400;">The response to both COVID-19 and the climate crisis must be worked on in tandem, and Caribbean leaders have </span><a href="https://www.greenclimate.fund/news/regional-dialogue-calls-scaled-climate-finance-hard-hit-caribbean-region" target="_blank" rel="noopener"><span style="font-weight: 400;">warned</span></a><span style="font-weight: 400;"> that the two threats are of equal importance to the region. Maintaining that access to finance must urgently be scaled up, the Prime Minister of Barbados, Mia Amor Mottley, recently stated that, “if the global community does not act quickly to make up for delays in financing commitments under the Paris Agreement, climate refugees fleeing the imminent threat of sea level rise and devastation from disaster will be every country’s responsibility.”</span></p>
<p><span style="font-weight: 400;">Dealing with last year’s sudden drop in tourism revenue, Small Island Developing States (SIDS) have had to look for new financial opportunities to support their economies. Many are calling for economic alternatives to tourism to be prioritised, but the availability of funds to make the investments necessary for these changes remains a key challenge for implementation. The Green Climate Fund represents one option, but criticism remains that the smaller or medium-scale funding needed for SIDS compared to larger nations can often be held back by red tape.</span></p>
<p><span style="font-weight: 400;">Bolstered by Gutteres’ </span><a href="https://www.climatechangenews.com/2021/02/08/antonio-guterres-calls-preparatory-un-climate-negotiations-held-online/" target="_blank" rel="noopener"><span style="font-weight: 400;">demand</span></a><span style="font-weight: 400;"> for more online participation ahead of the COP, in addition to the work carried out by the </span><a href="https://www.aosis.org/" target="_blank" rel="noopener"><span style="font-weight: 400;">Alliance of Small Island States</span></a><span style="font-weight: 400;"> (AOSIS) to call for better access to finance for island nations, virtual negotiations have become an important part of climate policy. This has promoted socio-economic growth among islands and led to </span><a href="https://virtualislandsummit.com/" target="_blank" rel="noopener"><span style="font-weight: 400;">high-level discussions</span></a><span style="font-weight: 400;"> geared at capitalizing on local knowledge and innovation. With the slow reopening of the global economy, there is also an important role for private finance institutions to prioritize sustainable development in their efforts.</span></p>
<p><b>Sustainable Recovery: </b><span style="font-weight: 400;">Now is the time for action, and green investments are a critical component in the next phase. A case for new investment mechanisms to finance the difficult years ahead must be made at the international level, including at the United Nations. Island citizens must demand their political leaders make the case for a global effort that leaves no nation behind and includes equitable access to finance for both national governments and for small businesses that form the backbone of island economies.</span></p>
<p><span style="font-weight: 400;">This week’s </span><a href="https://islandinnovation.co/finance-forum-2021/" target="_blank" rel="noopener"><span style="font-weight: 400;">Island Finance Forum</span></a><span style="font-weight: 400;"> will highlight the challenges faced by global island communities and is expected to help promote solutions for a sustainable economic recovery. Open to the public in a virtual format and featuring opportunities for Q&amp;A sessions with panelists, the event aims to illustrate how a fair and sustainable economic recovery can start from local grassroots programmes to high-level policy initiatives.</span></p>
<p><span style="font-weight: 400;"> Events like this, which help bridge the gap between sustainable development practitioners and stakeholders, and help to open access to expert knowledge and financial opportunities available to them, are an important step towards creating a strong future for island communities. </span></p>
<p><em>Image credit: St. Pierre, Martinique. Larry Syverson.</em></p>
<aside class="mashsb-container mashsb-main "><div class="mashsb-box"><div class="mashsb-buttons"><a class="mashicon-facebook mash-medium mashsb-noshadow" href="https://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.antillean.org%2Fisland-nations-equitable-recovery-covid-climate-change-9134%2F" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Share</span></a><a class="mashicon-twitter mash-medium mashsb-noshadow" href="https://twitter.com/intent/tweet?text=Equitable%20recovery%20now%20a%20key%20concern%20for%20island%20nations&url=https://wp.me/psTVf-4cK&via=antilleanmedia" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Tweet</span></a><a class="mashicon-subscribe mash-medium mashsb-noshadow" href="#" target="_top" rel="nofollow"><span class="icon"></span><span class="text">Subscribe</span></a><div class="onoffswitch2 mash-medium mashsb-noshadow" style="display:none;"></div></div>
            </div>
                <div style="clear:both;"></div><div class="mashsb-toggle-container"><!-- Begin MailChimp Signup Form -->
<link href="//cdn-images.mailchimp.com/embedcode/slim-10_7.css" rel="stylesheet" type="text/css">
<style type="text/css">
	#mc_embed_signup{background:#fff; clear:left; font:14px Helvetica,Arial,sans-serif; }
	/* Add your own MailChimp form style overrides in your site stylesheet or in this style block.
	   We recommend moving this block and the preceding CSS link to the HEAD of your HTML file. */
</style>
<div id="mc_embed_signup">
<form action="//antillean.us9.list-manage.com/subscribe/post?u=a87f50a393b71e179c5f277f5&amp;id=1215dbd259" method="post" id="mc-embedded-subscribe-form" name="mc-embedded-subscribe-form" class="validate" target="_blank" novalidate>
    <div id="mc_embed_signup_scroll">
	<label for="mce-EMAIL">If you like our journalism, subscribe to our news briefs and get the best of AMG delivered to your inbox. You can also <a href="https://www.facebook.com/antilleanmedia">like us on Facebook</a>.</label>
	<input type="email" value="" name="EMAIL" class="email" id="mce-EMAIL" placeholder="email address" required>
    <!-- real people should not fill this in and expect good things - do not remove this or risk form bot signups-->
    <div style="position: absolute; left: -5000px;" aria-hidden="true"><input type="text" name="b_a87f50a393b71e179c5f277f5_1215dbd259" tabindex="-1" value=""></div>
   <input type="submit" value="Subscribe" name="subscribe" id="mc-embedded-subscribe" class="button">
    </div>
</form>
</div>

<!--End mc_embed_signup--></div></aside>
            <!-- Share buttons by mashshare.net - Version: 3.7.9-->			</div><!-- .entry-content -->

	<footer class="entry-footer">
		<meta itemprop="interactionCount" content="UserComments:0">
			</footer><!-- .entry-footer -->

	<div id="post-meta">
		<h2 class="entry-title semantic" itemprop="headline">Equitable recovery now a key concern for island nations</h2>
		
		<div id="author-bio">
			<div class="author-avatar">
				<img alt src="https://secure.gravatar.com/avatar/761d51dcf65817ff1721ec675014c375?s=80&#038;r=g" class="avatar avatar-80 photo jetpack-lazy-image" height="80" width="80" loading="lazy" data-lazy-srcset="https://secure.gravatar.com/avatar/761d51dcf65817ff1721ec675014c375?s=160&#038;r=g 2x" data-lazy-src="https://secure.gravatar.com/avatar/761d51dcf65817ff1721ec675014c375?s=80&amp;is-pending-load=1#038;r=g" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7"><noscript><img alt='' src='https://secure.gravatar.com/avatar/761d51dcf65817ff1721ec675014c375?s=80&#038;r=g' srcset='https://secure.gravatar.com/avatar/761d51dcf65817ff1721ec675014c375?s=160&#038;r=g 2x' class='avatar avatar-80 photo' height='80' width='80' loading='lazy'/></noscript>			</div>

			<div class="author-information">

									<span class="author-name">
						<a href="https://www.antillean.org/author/jamesellsmoor/">James Ellsmoor</a>					</span>
				
				<p class="author-info">James Ellsmoor is the CEO of Island Innovation and founder of the Virtual Island Summit. The network connects thousands of islanders from around the world, using ‘digital bridges’ to share knowledge and encourage collaboration between islands and build a more sustainable future. Send feedback to james@islandinnovation.com</p>
			</div>
		</div>

		 
	<p class="author-bio"> PUBLISHED — April 13, 2021</p>
				<div class="entry-cats">
				<span>Category:</span>
				<a href="https://www.antillean.org/op-ed/" class="canos_cat" rel="category tag">Opinions &amp; Editorials</a><a href="https://www.antillean.org/sustainability/" class="canos_cat" rel="category tag">Sustainability</a>			</div><!-- .entry-cats -->
		 
	  <span class="comments-badge"><a href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/#respond">0</a></span>		<span class="posted-on semantic"><a href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2021-04-13T12:19:11-04:00">April 13, 2021</time><time class="updated semantic" itemprop="dateModified" datetime="2021-04-13T12:26:13-04:00">April 13, 2021</time></a></span>		<span class="byline semantic"> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/jamesellsmoor/"><span class="nickname" itemprop="name">James Ellsmoor</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/">		

		<div class="views">
					 </div> <!-- .views -->
	</div>
</article><!-- #post-## -->

			
				<aside id="related-posts">

					<h3>Related posts</h3>

					<div class="related-posts">

						
							<article class="post-13539 post type-post status-publish format-standard has-post-thumbnail hentry category-health category-op-ed tag-barbados tag-child-health tag-guyana tag-law tag-martinique tag-maternal-health tag-public-health tag-zika" itemscope="itemscope" itemtype="http://schema.org/Article">
								<h4 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/zika-pregnancy-advisories-999/" rel="bookmark">The problem with Zika pregnancy advisories</a></h4>
								<span class="posted-on "><a href="https://www.antillean.org/zika-pregnancy-advisories-999/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2016-02-08T16:34:42-05:00">February 8, 2016</time><time class="updated semantic" itemprop="dateModified" datetime="2016-05-22T21:54:14-04:00">May 22, 2016</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/sherinepowerful/"><span class="nickname" itemprop="name">Sherine Andreine Powerful</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/zika-pregnancy-advisories-999/">
			<div class="post-thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="150" height="150" src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2016/02/4482887906_5aa01a0c65_b-1.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/www.antillean.org/wp-content/uploads/2016/02/4482887906_5aa01a0c65_b-1.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2016/02/4482887906_5aa01a0c65_b-1.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2016/02/4482887906_5aa01a0c65_b-1.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2016/02/4482887906_5aa01a0c65_b-1.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />				<meta itemprop="url" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2016/02/4482887906_5aa01a0c65_b-1.jpg?resize=150%2C150&#038;ssl=1">
				<meta itemprop="width" content="150">
				<meta itemprop="height" content="150">
			</div>

		
								<div class="entry-summary" itemprop="text">
									<p>With links between the Zika virus and fetal abnormalities in babies born to infected mothers, the outbreak has become an issue of reproductive justice for the Caribbean&#8217;s women</p>
								</div><!-- .entry-summary -->
								<meta itemprop="interactionCount" content="UserComments:0">
							</article>

						
							<article class="post-10039 post type-post status-publish format-standard has-post-thumbnail hentry category-sustainability tag-caricom-policy tag-climate-change tag-disaster-risk tag-sustainable-development tag-bahamas" itemscope="itemscope" itemtype="http://schema.org/Article">
								<h4 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/water-conference-sheds-light-challenges-innovations-caribbean-nations/" rel="bookmark">Water conference sheds light on challenges and innovations of Caribbean nations</a></h4>
								<span class="posted-on "><a href="https://www.antillean.org/water-conference-sheds-light-challenges-innovations-caribbean-nations/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2014-10-14T22:02:15-04:00">October 14, 2014</time><time class="updated semantic" itemprop="dateModified" datetime="2015-10-03T13:04:09-04:00">October 3, 2015</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/alisonsinger/"><span class="nickname" itemprop="name">Alison Singer</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/water-conference-sheds-light-challenges-innovations-caribbean-nations/">
			<div class="post-thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="150" height="150" src="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/10/xcwwa-conference-opening_bahamas2014_cwwa-pic.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/10/xcwwa-conference-opening_bahamas2014_cwwa-pic.jpg?resize=150%2C150&amp;ssl=1 150w, https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/10/xcwwa-conference-opening_bahamas2014_cwwa-pic.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w, https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/10/xcwwa-conference-opening_bahamas2014_cwwa-pic.jpg?zoom=3&amp;resize=150%2C150&amp;ssl=1 450w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/10/xcwwa-conference-opening_bahamas2014_cwwa-pic.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />				<meta itemprop="url" content="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/10/xcwwa-conference-opening_bahamas2014_cwwa-pic.jpg?resize=150%2C150&#038;ssl=1">
				<meta itemprop="width" content="150">
				<meta itemprop="height" content="150">
			</div>

		
								<div class="entry-summary" itemprop="text">
									<p>The Caribbean Water and Wastewater Association recently held its annual conference in the Bahamas, under the theme of Water, Waste, and Energy in the Caribbean</p>
								</div><!-- .entry-summary -->
								<meta itemprop="interactionCount" content="UserComments:0">
							</article>

						
							<article class="post-12798 post type-post status-publish format-standard has-post-thumbnail hentry category-sustainability tag-antigua-barbuda tag-disaster-risk tag-dominica" itemscope="itemscope" itemtype="http://schema.org/Article">
								<h4 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/ronald-sanders-urgent-help-dominica-858/" rel="bookmark">Antigua &#038; Barbuda government calls for urgent international aid to Dominica</a></h4>
								<span class="posted-on "><a href="https://www.antillean.org/ronald-sanders-urgent-help-dominica-858/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2015-08-28T10:24:00-04:00">August 28, 2015</time><time class="updated semantic" itemprop="dateModified" datetime="2015-08-28T10:47:33-04:00">August 28, 2015</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/antillean23/"><span class="nickname" itemprop="name">Antillean Media Group</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/ronald-sanders-urgent-help-dominica-858/">
			<div class="post-thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="150" height="150" src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=1104%2C1104&amp;ssl=1 1104w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=912%2C912&amp;ssl=1 912w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=550%2C550&amp;ssl=1 550w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=470%2C470&amp;ssl=1 470w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />				<meta itemprop="url" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2015/08/20380832868_29a49419ad_k-e1440605136584.jpg?resize=150%2C150&#038;ssl=1">
				<meta itemprop="width" content="150">
				<meta itemprop="height" content="150">
			</div>

		
								<div class="entry-summary" itemprop="text">
									<p>Antigua and Barbuda diplomat, Sir Ronald Sanders, has called on the international community to provide emergency relief to Dominica</p>
								</div><!-- .entry-summary -->
								<meta itemprop="interactionCount" content="UserComments:1">
							</article>

						
							<article class="post-10918 post type-post status-publish format-standard has-post-thumbnail hentry category-foreign-policy category-op-ed tag-democracy tag-governance tag-jamaica tag-law tag-s1" itemscope="itemscope" itemtype="http://schema.org/Article">
								<h4 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/jamaica-voter-apathy-comes-cost-democracy/" rel="bookmark">In Jamaica, voter apathy comes at a cost for democracy</a></h4>
								<span class="posted-on "><a href="https://www.antillean.org/jamaica-voter-apathy-comes-cost-democracy/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2014-12-22T12:39:21-05:00">December 22, 2014</time><time class="updated semantic" itemprop="dateModified" datetime="2015-10-08T00:18:20-04:00">October 8, 2015</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/daytoncampbell/"><span class="nickname" itemprop="name">Dr. Dayton Campbell</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/jamaica-voter-apathy-comes-cost-democracy/">
			<div class="post-thumbnail" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
				<img width="150" height="150" src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2014/12/unnamed21.jpg?resize=150%2C150&amp;ssl=1" class="attachment-thumbnail size-thumbnail wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/www.antillean.org/wp-content/uploads/2014/12/unnamed21.jpg?resize=150%2C150&amp;ssl=1 150w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2014/12/unnamed21.jpg?resize=470%2C470&amp;ssl=1 470w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2014/12/unnamed21.jpg?zoom=2&amp;resize=150%2C150&amp;ssl=1 300w" data-lazy-sizes="(max-width: 150px) 100vw, 150px" data-lazy-src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2014/12/unnamed21.jpg?resize=150%2C150&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />				<meta itemprop="url" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2014/12/unnamed21.jpg?resize=150%2C150&#038;ssl=1">
				<meta itemprop="width" content="150">
				<meta itemprop="height" content="150">
			</div>

		
								<div class="entry-summary" itemprop="text">
									<p>Jamaican Member of Parliament Dayton Campbell suggests that a silent majority of apathetic voters is impacting Jamaica&#8217;s democracy, and suggests ways to change this reality</p>
								</div><!-- .entry-summary -->
								<meta itemprop="interactionCount" content="UserComments:1">
							</article>

						
					</div>

				</aside>

			
					<nav class="navigation post-navigation" role="navigation">
			<h3 class="screen-reader-text">Post navigation</h3>
			<div class="nav-links">
				<div class="nav-previous nav-post"><a href="https://www.antillean.org/future-caribbean-insurance-risk-0183/" rel="prev"><span class="meta-nav">Previous story</span></a></div>			</div><!-- .nav-links -->
		</nav><!-- .navigation -->
		
			
<div id="comments" class="comments-area">

	
	
	
	
	
		<div id="respond" class="comment-respond">
							<h3 id="reply-title" class="comment-reply-title">Leave a Reply					<small><a rel="nofollow" id="cancel-comment-reply-link" href="/island-nations-equitable-recovery-covid-climate-change-9134/#respond" style="display:none;">Cancel reply</a></small>
				</h3>
						<form id="commentform" class="comment-form">
				<iframe
					title="Comment Form"
					src="https://jetpack.wordpress.com/jetpack-comment/?blogid=6888153&#038;postid=16166&#038;comment_registration=0&#038;require_name_email=1&#038;stc_enabled=0&#038;stb_enabled=1&#038;show_avatars=1&#038;avatar_default=gravatar_default&#038;greeting=Leave+a+Reply&#038;greeting_reply=Leave+a+Reply+to+%25s&#038;color_scheme=light&#038;lang=en_US&#038;jetpack_version=9.6.1&#038;show_cookie_consent=10&#038;has_cookie_consent=0&#038;token_key=%3Bnormal%3B&#038;sig=0bc9b674bd3b3586b415620ba1e49689c9790d22#parent=https%3A%2F%2Fwww.antillean.org%2Fisland-nations-equitable-recovery-covid-climate-change-9134%2F"
											name="jetpack_remote_comment"
						style="width:100%; height: 430px; border:0;"
										class="jetpack_remote_comment"
					id="jetpack_remote_comment"
					sandbox="allow-same-origin allow-top-navigation allow-scripts allow-forms allow-popups"
				>
									</iframe>
									<!--[if !IE]><!-->
					<script>
						document.addEventListener('DOMContentLoaded', function () {
							var commentForms = document.getElementsByClassName('jetpack_remote_comment');
							for (var i = 0; i < commentForms.length; i++) {
								commentForms[i].allowTransparency = false;
								commentForms[i].scrolling = 'no';
							}
						});
					</script>
					<!--<![endif]-->
							</form>
		</div>

		
		<input type="hidden" name="comment_parent" id="comment_parent" value="" />

		
</div><!-- #comments -->

		
		</main><!-- #main -->
	</div><!-- #primary -->


<div id="secondary" class="widget-area" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar">
	<aside id="search-3" class="widget widget_search"><form role="search" method="get" class="search-form" action="https://www.antillean.org/">
				<label>
					<span class="screen-reader-text">Search for:</span>
					<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s" />
				</label>
				<input type="submit" class="search-submit" value="Search" />
			</form></aside><aside id="canos_widget_newsletter-2" class="widget canos_widget_newsletter">
		<div class="canos-item-newsletter">

							<h4 class="widget-title">Sign up to get our most important briefings from around the Caribbean</h4>
			
			<form class="canos-newsletter-form" name="canos-newsletter-form" action="#" method="post" data-name="no" data-confirm="welcome-email">

				
				<p class="canos-newsletter-field">
					<label>Email Address</label>
					<input type="email" placeholder="Email Address" class="canos-newsletter-email">
				</p>

				<input type="hidden" class="canos-newsletter-list-id" value="1215dbd259" />

				<input type="submit" value="Subscribe" class="canos-newsletter-button">
				
				<div class="canos-newsletter-loader"></div>
				<div class="clearfix"></div>

			</form>

			<div class="canos-newsletter-response"></div>

		</div>

		</aside><aside id="canos_widget_social-2" class="widget canos_widget_social"><h4 class="widget-title">Follow @antilleanmedia</h4>
					
		<ul class="site-follow">
							<li><a href="http://www.facebook.com/antilleanmedia" target=&quot;_blank&quot;><i class="fa fa-facebook"></i></a></li>
										<li><a href="http://www.twitter.com/antilleanmedia" target=&quot;_blank&quot;><i class="fa fa-twitter"></i></a></li>
													<li><a href="https://www.linkedin.com/company/antilleanmedia" target=&quot;_blank&quot;><i class="fa fa-linkedin"></i></a></li>
																																																																	</ul>
	
		</aside>
		<aside id="canos_widget_module_recent-2" class="widget canos_widget_module_recent">
		<h4 class="widget-title">Recent updates</h4>
		
			<article class="post-16166 post type-post status-publish format-standard has-post-thumbnail hentry category-op-ed category-sustainability" itemscope="itemscope" itemtype="http://schema.org/Article">

				
		<a class="post-thumbnail " href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
			<img width="100" height="90" src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=100%2C90&amp;ssl=1" class="attachment-canos_100x90 size-canos_100x90 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=100%2C90&amp;ssl=1 100w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?zoom=2&amp;resize=100%2C90&amp;ssl=1 200w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?zoom=3&amp;resize=100%2C90&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=100%2C90&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			<meta itemprop="url" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/04/50682282238_955c27f09e_c.jpg?resize=100%2C90&#038;ssl=1">
		    <meta itemprop="width" content="100">
		    <meta itemprop="height" content="90">
		</a>

		
				<header class="entry-header">
					<h2 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" rel="bookmark">Equitable recovery now a key concern for island nations</a></h2>				</header><!-- .entry-header -->

				<span class="posted-on "><a href="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2021-04-13T12:19:11-04:00">April 13, 2021</time><time class="updated semantic" itemprop="dateModified" datetime="2021-04-13T12:26:13-04:00">April 13, 2021</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/jamesellsmoor/"><span class="nickname" itemprop="name">James Ellsmoor</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/island-nations-equitable-recovery-covid-climate-change-9134/">
				
				<footer class="entry-footer">
					<meta itemprop="interactionCount" content="UserComments:0">
				</footer><!-- .entry-footer -->

			</article><!-- #post-## -->
		
			<article class="post-16144 post type-post status-publish format-standard has-post-thumbnail hentry category-op-ed" itemscope="itemscope" itemtype="http://schema.org/Article">

				
		<a class="post-thumbnail " href="https://www.antillean.org/future-caribbean-insurance-risk-0183/" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
			<img width="100" height="90" src="https://i1.wp.com/www.antillean.org/wp-content/uploads/2021/03/36531124633_396454f5d1_c.jpg?resize=100%2C90&amp;ssl=1" class="attachment-canos_100x90 size-canos_100x90 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i1.wp.com/www.antillean.org/wp-content/uploads/2021/03/36531124633_396454f5d1_c.jpg?resize=100%2C90&amp;ssl=1 100w, https://i1.wp.com/www.antillean.org/wp-content/uploads/2021/03/36531124633_396454f5d1_c.jpg?zoom=2&amp;resize=100%2C90&amp;ssl=1 200w, https://i1.wp.com/www.antillean.org/wp-content/uploads/2021/03/36531124633_396454f5d1_c.jpg?zoom=3&amp;resize=100%2C90&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/www.antillean.org/wp-content/uploads/2021/03/36531124633_396454f5d1_c.jpg?resize=100%2C90&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			<meta itemprop="url" content="https://i1.wp.com/www.antillean.org/wp-content/uploads/2021/03/36531124633_396454f5d1_c.jpg?resize=100%2C90&#038;ssl=1">
		    <meta itemprop="width" content="100">
		    <meta itemprop="height" content="90">
		</a>

		
				<header class="entry-header">
					<h2 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/future-caribbean-insurance-risk-0183/" rel="bookmark">The future of Caribbean property and casualty insurance</a></h2>				</header><!-- .entry-header -->

				<span class="posted-on "><a href="https://www.antillean.org/future-caribbean-insurance-risk-0183/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2021-03-19T20:01:26-04:00">March 19, 2021</time><time class="updated semantic" itemprop="dateModified" datetime="2021-03-19T20:07:25-04:00">March 19, 2021</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/andrewright/"><span class="nickname" itemprop="name">André Wright + Joseph L. Moore</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/future-caribbean-insurance-risk-0183/">
				
				<footer class="entry-footer">
					<meta itemprop="interactionCount" content="UserComments:0">
				</footer><!-- .entry-footer -->

			</article><!-- #post-## -->
		
			<article class="post-16132 post type-post status-publish format-standard has-post-thumbnail hentry category-health category-op-ed category-travel" itemscope="itemscope" itemtype="http://schema.org/Article">

				
		<a class="post-thumbnail " href="https://www.antillean.org/vaccine-passports-caribbean-tourism-1391/" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
			<img width="100" height="90" src="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/03/0015642981951_c627440ba8_k.jpg?resize=100%2C90&amp;ssl=1" class="attachment-canos_100x90 size-canos_100x90 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/03/0015642981951_c627440ba8_k.jpg?resize=100%2C90&amp;ssl=1 100w, https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/03/0015642981951_c627440ba8_k.jpg?zoom=2&amp;resize=100%2C90&amp;ssl=1 200w, https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/03/0015642981951_c627440ba8_k.jpg?zoom=3&amp;resize=100%2C90&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/03/0015642981951_c627440ba8_k.jpg?resize=100%2C90&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			<meta itemprop="url" content="https://i1.wp.com/www.antillean.org/wp-content/uploads/2014/03/0015642981951_c627440ba8_k.jpg?resize=100%2C90&#038;ssl=1">
		    <meta itemprop="width" content="100">
		    <meta itemprop="height" content="90">
		</a>

		
				<header class="entry-header">
					<h2 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/vaccine-passports-caribbean-tourism-1391/" rel="bookmark">Vaccine passports could drive Caribbean tourism recovery</a></h2>				</header><!-- .entry-header -->

				<span class="posted-on "><a href="https://www.antillean.org/vaccine-passports-caribbean-tourism-1391/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2021-02-26T07:47:18-05:00">February 26, 2021</time><time class="updated semantic" itemprop="dateModified" datetime="2021-02-26T07:48:34-05:00">February 26, 2021</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/davidjessop/"><span class="nickname" itemprop="name">David Jessop, Expert Contributor</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/vaccine-passports-caribbean-tourism-1391/">
				
				<footer class="entry-footer">
					<meta itemprop="interactionCount" content="UserComments:0">
				</footer><!-- .entry-footer -->

			</article><!-- #post-## -->
		
			<article class="post-16106 post type-post status-publish format-standard has-post-thumbnail hentry category-headlines category-health" itemscope="itemscope" itemtype="http://schema.org/Article">

				
		<a class="post-thumbnail " href="https://www.antillean.org/vaccine-inequity-comonwealth-3919/" itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
			<img width="100" height="90" src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/02/48707841732_b265f53478_c.jpg?resize=100%2C90&amp;ssl=1" class="attachment-canos_100x90 size-canos_100x90 wp-post-image jetpack-lazy-image" alt="" loading="lazy" data-lazy-srcset="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/02/48707841732_b265f53478_c.jpg?resize=100%2C90&amp;ssl=1 100w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/02/48707841732_b265f53478_c.jpg?zoom=2&amp;resize=100%2C90&amp;ssl=1 200w, https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/02/48707841732_b265f53478_c.jpg?zoom=3&amp;resize=100%2C90&amp;ssl=1 300w" data-lazy-sizes="(max-width: 100px) 100vw, 100px" data-lazy-src="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/02/48707841732_b265f53478_c.jpg?resize=100%2C90&amp;ssl=1&amp;is-pending-load=1" srcset="data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7" />			<meta itemprop="url" content="https://i2.wp.com/www.antillean.org/wp-content/uploads/2021/02/48707841732_b265f53478_c.jpg?resize=100%2C90&#038;ssl=1">
		    <meta itemprop="width" content="100">
		    <meta itemprop="height" content="90">
		</a>

		
				<header class="entry-header">
					<h2 itemprop="headline" class="entry-title"><a itemprop="url" href="https://www.antillean.org/vaccine-inequity-comonwealth-3919/" rel="bookmark">Vaccine inequity will cost lives in small countries</a></h2>				</header><!-- .entry-header -->

				<span class="posted-on "><a href="https://www.antillean.org/vaccine-inequity-comonwealth-3919/" rel="bookmark"><time class="entry-date published" itemprop="datePublished" datetime="2021-02-24T18:24:33-05:00">February 24, 2021</time><time class="updated semantic" itemprop="dateModified" datetime="2021-02-26T07:47:54-05:00">February 26, 2021</time></a></span><span class="byline "> Written by <span class="author vcard" itemprop="author" itemscope="itemscope" itemtype="http://schema.org/Person"><a itemprop="url" rel="author" class="url fn" href="https://www.antillean.org/author/antillean23/"><span class="nickname" itemprop="name">Antillean Media Group</span></a></span></span><div class="semantic" itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><img src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"><meta itemprop="url" content="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png"></div><meta itemprop="name" content="Antillean Media Group"></div><meta itemscope itemprop="mainEntityOfPage" itemType="https://schema.org/WebPage" itemid="https://www.antillean.org/vaccine-inequity-comonwealth-3919/">
				
				<footer class="entry-footer">
					<meta itemprop="interactionCount" content="UserComments:0">
				</footer><!-- .entry-footer -->

			</article><!-- #post-## -->
		
		</aside>
		<aside id="eu_cookie_law_widget-2" class="widget widget_eu_cookie_law_widget">
<div
	class="hide-on-button"
	data-hide-timeout="30"
	data-consent-expiration="180"
	id="eu-cookie-law"
>
	<form method="post">
		<input type="submit" value="Close and accept" class="accept" />
	</form>

	Privacy &amp; Cookies: This site uses cookies. By continuing to use this website, you agree to their use. <br />
To find out more, including how to control cookies, see here:
		<a href="https://www.antillean.org/privacy/" rel="">
		Privacy policy	</a>
</div>
</aside></div><!-- #secondary -->


	</div><!-- #content -->

	<footer id="colophon" class="site-footer" role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter">

		<div class="wrap">

			
				
					
					<a href="https://www.antillean.org/" rel="home" class="site-logo"><img id="footer-desktop-logo" src="https://www.antillean.org/wp-content/uploads/2019/01/logo-reg-blue-1.png" alt="Antillean Media Group" width="300" height="111">
																				<img id="footer-retina-logo" src="https://www.antillean.org/wp-content/uploads/2019/01/logo-ret-blue-1.png" alt="Antillean Media Group" width="600" height="222">
											</a>
					
				
			
											<div id="footer-menu" class="menu-top-container"><ul id="menu-top" class="menu"><li id="menu-item-15169" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15169"><a href="https://www.antillean.org/about-us/">About us</a></li>
<li id="menu-item-11788" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-11788"><a href="https://www.antillean.org/jobs/">Work with us</a></li>
<li id="menu-item-15706" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15706"><a href="https://www.antillean.org/caribbean-consultancy-services/">Commercial services</a></li>
<li id="menu-item-15219" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15219"><a href="https://www.antillean.org/reprints/">Reprints</a></li>
<li id="menu-item-15111" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-15111"><a href="https://www.antillean.org/privacy/">Privacy policy</a></li>
<li id="menu-item-9028" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9028"><a href="https://www.antillean.org/contact-us/">Contact us</a></li>
</ul></div>							
			
			<div class="site-description" itemprop="description">
				AMG explains the Caribbean through authoritative insights on the issues that shape the region&#039;s politics, markets, and people. We approach the news differently, with an editorial team of researchers and policy analysts that goes beyond the media&#039;s headlines, with incisive briefs on the Caribbean&#039;s most important issues. Copyright ©, Antillean Development Partners Inc., 2013-2020. All rights reserved.			</div><!-- .site-description -->

			
			<a id="back-top" href="#masthead">Back to top</a>

		</div><!-- .wrap -->

	</footer><!-- #colophon -->
</div><!-- #page -->

		<!-- Quantcast Tag -->
		<script type="text/javascript">
			var _qevents = _qevents || [];

			(function() {
				var elem = document.createElement('script');
				elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
				elem.async = true;
				elem.type = "text/javascript";
				var scpt = document.getElementsByTagName('script')[0];
				scpt.parentNode.insertBefore(elem, scpt);
			})();

			_qevents.push({
				qacct:"p-5Kb58_EHUaAye",
				source:"wp"
			});
		</script>

		<noscript>
		<div style="display:none;">
			<img src="//pixel.quantserve.com/pixel/p-5Kb58_EHUaAye.gif" border="0" height="1" width="1" alt="Quantcast"/>
		</div>
		</noscript>
		<!-- End Quantcast tag -->
		<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.6.1/_inc/build/photon/photon.min.js' id='jetpack-photon-js'></script>
<script type='text/javascript' id='mailchimp-js-js-extra'>
/* <![CDATA[ */
var canos_framework_process_form_vars = {"ajaxurl":"https:\/\/www.antillean.org\/wp-admin\/admin-ajax.php","nonce":"d8a6a24723"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.antillean.org/wp-content/plugins/canos-framework/public/js/canos-mailchimp.js?ver=1.2.0' id='mailchimp-js-js'></script>
<script type='text/javascript' src='https://www.antillean.org/wp-content/themes/amgos/js/canos.js?ver=5.7.1' id='canos-main-js-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/comment-reply.min.js' id='comment-reply-js'></script>
<script type='text/javascript' src='https://c0.wp.com/p/jetpack/9.6.1/_inc/build/widgets/eu-cookie-law/eu-cookie-law.min.js' id='eu-cookie-law-script-js'></script>
<script type='text/javascript' src='https://www.antillean.org/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/intersectionobserver-polyfill.min.js?ver=1.1.2' id='jetpack-lazy-images-polyfill-intersectionobserver-js'></script>
<script type='text/javascript' id='jetpack-lazy-images-js-extra'>
/* <![CDATA[ */
var jetpackLazyImagesL10n = {"loading_warning":"Images are still loading. Please cancel your print and try again."};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.antillean.org/wp-content/plugins/jetpack/vendor/automattic/jetpack-lazy-images/src/js/lazy-images.min.js?ver=1.1.2' id='jetpack-lazy-images-js'></script>
<script type='text/javascript' src='https://c0.wp.com/c/5.7.1/wp-includes/js/wp-embed.min.js' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://www.antillean.org/wp-content/plugins/akismet/_inc/form.js?ver=4.1.9' id='akismet-form-js'></script>

		<!--[if IE]>
		<script type="text/javascript">
			if ( 0 === window.location.hash.indexOf( '#comment-' ) ) {
				// window.location.reload() doesn't respect the Hash in IE
				window.location.hash = window.location.hash;
			}
		</script>
		<![endif]-->
		<script type="text/javascript">
			(function () {
				var comm_par_el = document.getElementById( 'comment_parent' ),
					comm_par = ( comm_par_el && comm_par_el.value ) ? comm_par_el.value : '',
					frame = document.getElementById( 'jetpack_remote_comment' ),
					tellFrameNewParent;

				tellFrameNewParent = function () {
					if ( comm_par ) {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=6888153&postid=16166&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0bc9b674bd3b3586b415620ba1e49689c9790d22#parent=https%3A%2F%2Fwww.antillean.org%2Fisland-nations-equitable-recovery-covid-climate-change-9134%2F" + '&replytocom=' + parseInt( comm_par, 10 ).toString();
					} else {
						frame.src = "https://jetpack.wordpress.com/jetpack-comment/?blogid=6888153&postid=16166&comment_registration=0&require_name_email=1&stc_enabled=0&stb_enabled=1&show_avatars=1&avatar_default=gravatar_default&greeting=Leave+a+Reply&greeting_reply=Leave+a+Reply+to+%25s&color_scheme=light&lang=en_US&jetpack_version=9.6.1&show_cookie_consent=10&has_cookie_consent=0&token_key=%3Bnormal%3B&sig=0bc9b674bd3b3586b415620ba1e49689c9790d22#parent=https%3A%2F%2Fwww.antillean.org%2Fisland-nations-equitable-recovery-covid-climate-change-9134%2F";
					}
				};

				
				if ( 'undefined' !== typeof addComment ) {
					addComment._Jetpack_moveForm = addComment.moveForm;

					addComment.moveForm = function ( commId, parentId, respondId, postId ) {
						var returnValue = addComment._Jetpack_moveForm( commId, parentId, respondId, postId ),
							cancelClick, cancel;

						if ( false === returnValue ) {
							cancel = document.getElementById( 'cancel-comment-reply-link' );
							cancelClick = cancel.onclick;
							cancel.onclick = function () {
								var cancelReturn = cancelClick.call( this );
								if ( false !== cancelReturn ) {
									return cancelReturn;
								}

								if ( ! comm_par ) {
									return cancelReturn;
								}

								comm_par = 0;

								tellFrameNewParent();

								return cancelReturn;
							};
						}

						if ( comm_par == parentId ) {
							return returnValue;
						}

						comm_par = parentId;

						tellFrameNewParent();

						return returnValue;
					};
				}

				
				// Do the post message bit after the dom has loaded.
				document.addEventListener( 'DOMContentLoaded', function () {
					var iframe_url = "https:\/\/jetpack.wordpress.com";
					if ( window.postMessage ) {
						if ( document.addEventListener ) {
							window.addEventListener( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						} else if ( document.attachEvent ) {
							window.attachEvent( 'message', function ( event ) {
								var origin = event.origin.replace( /^http:\/\//i, 'https://' );
								if ( iframe_url.replace( /^http:\/\//i, 'https://' ) !== origin ) {
									return;
								}
								jQuery( frame ).height( event.data );
							});
						}
					}
				})

			})();
		</script>

		<script src='https://stats.wp.com/e-202116.js' defer></script>
<script>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:9.6.1',blog:'6888153',post:'16166',tz:'-4',srv:'www.antillean.org'} ]);
	_stq.push([ 'clickTrackerInit', '6888153', '16166' ]);
</script>

</body>
</html>
